SlideShare a Scribd company logo
1 of 36
Download to read offline
v
Cumulus Linux Conversion Guides
Cumulus Networks
May 24, 2016
Evolution of the CLI
§Where did things move?
cumulusnetworks.com 2
interfaces {
ge-0/1/1 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 100;
}
}
}
ge-0/1/2 {
unit 0 {
family bridge {
interface-mode access;
vlan-id 200;
}
}
}
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports swp1 swp2
bridge-vids 100 200
auto swp1
iface swp1
bridge-access 100
auto swp2
iface swp2
bridge-access 200
▪ Cisco ▪ Juniper ▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode access
switchport access vlan 100
interface ethernet 1/2
switchport mode access
switchport access vlan 200
Defining a Switch Port
cumulusnetworks.com 3
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
auto bridge
iface bridge
bridge-ports swp1
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport
Adding an IP Address
cumulusnetworks.com 4
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
address [ipv4-address/subnet-mask]
address [ipv6-address/subnet-mask]
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# no switchport
switch(config-if)# ip address [ipv4-address/subnet-mask]
switch(config-if)# ipv6 address [ipv6-address/subnet-mask]
Setting Speed, Duplex, MTU, and Auto-negotiation for an Interface
cumulusnetworks.com 5
cumulus@switch:~$ sudo vi /etc/network/interfaces
auto swp1
iface swp1
link-speed [speed]
link-duplex [full|half]
mtu [1500 - 9216]
link-autoneg [on|off]
Cumulus Linux
Cisco
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# speed [speed]
switch(config-if)# duplex [full|half]
switch(config-if)# mtu [1500 - 9216]
switch(config-if)# [no] negotiate auto
Configuring Trunks
cumulusnetworks.com 6
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode trunk
interface ethernet 1/2
switchport mode trunk
Cisco
Pruning a Trunk
cumulusnetworks.com 7
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
auto swp1
iface swp1
bridge-vids 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode trunk
switchport trunk allowed vlan 200
interface ethernet 1/2
switchport mode trunk
Cisco
Configuring Access Ports
cumulusnetworks.com 8
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 100 200
auto swp1
iface swp1
bridge-access 100
auto swp2
iface swp2
bridge-access 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 100,200
interface ethernet 1/1
switchport mode access
switchport access vlan 100
interface ethernet 1/2
switchport mode access
switchport access vlan 200
Cisco
Changing the Native (Untagged) VLAN for a Single Trunk
cumulusnetworks.com 9
auto bridge
iface bridge
bridge-vlan-aware yes
bridge-ports glob swp1-2
bridge-vids 1-200
auto swp1
iface swp1
bridge-pvid 100
auto swp2
iface swp2
bridge-pvid 200
▪ Cumulus Linux
/etc/network/interfaces:
vlan 1-200
interface ethernet 1/1-2
switchport mode trunk
switchport trunk allowed vlan 1-200
interface ethernet 1/1
switchport trunk native vlan 100
interface ethernet 1/2
switchport trunk native vlan 200
Cisco
EtherChannels/Bonds
cumulusnetworks.com 10
vlan 10
!
interface GigabitEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface GigabitEthernet0/20
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan10
ip address 10.10.10.10 255.255.255.0
Cisco WS-C3560X-24 12.2(55)SE5
auto bond1
iface bond1
bond-slaves glob swp19-20
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan10
iface vlan10
bridge-ports bond1.10
address 10.10.10.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Cisco
EtherChannels/Bonds
cumulusnetworks.com 11
interface Ethernet37
switchport mode trunk
channel-group 2 mode active
interface Ethernet38
switchport mode trunk
channel-group 2 mode active
interface Port-Channel2
switchport trunk allowed vlan 12
switchport mode trunk
interface Vlan12
ip address 12.12.12.12/24
Arista DCS-7148S-R 4.13.5F
auto bond2
iface bond2
bond-slaves glob swp37-38
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan12
iface vlan12
bridge-ports bond2.12
address 12.12.12.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Arista
EtherChannels/Bonds
cumulusnetworks.com 12
feature interface-vlan
feature lacp
vlan 14
interface Ethernet1/39
switchport mode trunk
channel-group 3 mode active
interface Ethernet1/40
switchport mode trunk
channel-group 3 mode active
interface port-channel3
switchport mode trunk
interface Vlan14
no shutdown
ip address 14.14.14.14/24
Cisco Nexus3064 5.0(3)U2(2c)
auto bond3
iface bond3
bond-slaves glob swp39-40
bond-miimon 100
bond-min-links 1
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
bond-lacp-rate 1
auto vlan14
iface vlan14
bridge-ports bond3.14
address 14.14.14.11/24
bridge-stp on
▪ Cumulus Linux
/etc/network/interfaces:
Cisco
Spanning Tree Configuration
cumulusnetworks.com 13
auto swp1
iface swp1
mstpctl-portadminedge yes
interface Gigabit0/0
spanning-tree portfast
Immediately bring an interface configured as an access or trunk port to the forwarding state.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 14
auto swp1
iface swp1
mstpctl-bpduguard yes
!
spanning-tree portfast bpduguard default
!
interface Gigabit0/0
spanning-tree portfast
Enabling/disabling the BPDU guard configuration.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 15
auto swp1
iface swp1
mstpctl-portbpdufilter yes
!
spanning-tree portfast bpdufilter default
!
interface Gigabit0/0
spanning-tree portfast
Enables BPDU filter on a switch port, which filters BPDUs in both directions.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 16
auto swp1
iface swp1
mstpctl-treeportprio 128
interface Gigabit0/0
spanning-tree port-priority 128
Configure the port priority for an interface. The default for both operating systems is 128.
▪ Cumulus Linux Cisco
Spanning Tree Configuration
cumulusnetworks.com 17
auto vlan1
iface vlan1
mstpctl-treeprio 32768
bridge-ports swp1
spanning-tree vlan 1 priority 32768
Configure the switch's priority for a bridge/VLAN. The default for both operating systems is 32768.
▪ Cumulus Linux Cisco
More Spanning Tree Info (Conversion Guide)
cumulusnetworks.com 18
https://support.cumulusnetworks.com/hc/en-us/articles/206908397
Spanning Tree
Industry-standard Loop Prevention for L2
Access Lists
cumulusnetworks.com 19
iptables -A {FORWARD | INPUT | OUTPUT} -j {ACCEPT | DROP | POLICE | SPAN | ERSPAN} | -p <protocol>
-s <source> --sport [<ports>] -d destination> --dport [<ports>] [<options>]
iptables -A FORWARD -j ACCEPT -p tcp -s 10.10.10.0/24 -d 3.3.3.3/24 --dport 80
iptables/netfilter (including Cumulus Linux)
access-list <number> {permit | deny} <protocol> <source> [<ports>] <destination> [<ports>] [<options>]
IOS Standard Syntax
ip access-list extended {<number> | <name>}
[<sequence>] {permit | deny} <protocol> <source> [<ports>]<destination> [<ports>] [<options>]
IOS Extended Syntax (including NX-OS)
ip access-list extended allow_http
10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www
access-list 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www
(Example permit http port 80 traffic to 10.10.10.0/24 subnet)
Block ICMP Echo Requests on the Specified Switch Port
cumulusnetworks.com 20
iptables -A FORWARD -j DROP -i swp1 -p icmp --icmp-type echo-request
ip access-list extended block_icmp
deny icmp any any echo
interface g0/0
ip access-group block_icmp in
Cumulus Linux
Cisco
Block SSH Trafficfrom the Specified Subnet (5.5.5.0/24)
cumulusnetworks.com 21
iptables -A INPUT -j DROP -p tcp -s 5.5.5.0/24 --dport 22
ip access-list extended block_ssh
deny tcp 5.5.5.0 0.0.0.255 192.50.50.0 0.0.0.255 eq 22
interface g0/0
ip access-group block_ssh in
Cumulus Linux
Cisco
Allow NTP Traffic to Transitthe Switch (UDP Port 123)
cumulusnetworks.com 22
iptables -A FORWARD -j ACCEPT -p udp -s 192.168.1.0/24 --dport 123
ip access-list extended allow_ntp
permit udp 192.168.1.0 0.0.0.255 any eq ntp
interface g0/0
ip access-group allow_ntp in
Cumulus Linux
Cisco
Policing a Physical Interface
cumulusnetworks.com 23
-A FORWARD --in-interface swp1 -j POLICE --set-mode KB --set-rate 125000 --set-burst 2000
Cumulus Linux
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp1
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp1 any anywhere anywhere POLICE mode:KB rate:125000 burst:2000
Output
policy-map sean
class class-default
police cir 1000000000 interface
TenGigabitEthernet1/13
service-policy input sean
Cisco
Policing DSCP Values
cumulusnetworks.com 24
-A FORWARD --in-interface swp2 -m dscp --dscp 10 -j POLICE --set-mode KB --set-rate 31250 --set-burst 2000
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp2
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp2 any anywhere anywhere DSCP match 0x0a POLICE mode:KB rate:31250 burst:2000
Cumulus Linux
Output
class-map match-all dscp10
match dscp af11
!
policy-map sean2
class dscp10
police cir 250000000
!
interface TenGigabitEthernet1/14
service-policy input sean2
Cisco
Policing by Source Traffic
cumulusnetworks.com 25
-A FORWARD --in-interface swp3 -j POLICE --set-mode KB --set-rate 12500 --set-burst 2000 -s 3.3.3.0/24
cumulus@leaf1$ sudo cl-acltool -L ip | grep swp3
pkts bytes target prot opt in out source destination
0 0 POLICE all -- swp3 any 3.3.3.0/24 anywhere POLICE mode:KB rate:12500 burst:2000
Cumulus Linux
access-list 100 permit ip 3.3.3.0 0.0.0.255 any
!
class-map match-all heller
match access-group 100
!
policy-map heller
class heller
police cir 100000000
!
interface TenGigabitEthernet1/15
service-policy input heller
Cisco
Output
Time Zone Configuration
cumulusnetworks.com 26
switch# configure terminal
switch(config)# clock timezone PST -8 0
switch(config)# exit
switch# show clock
switch# copy running-config startup-config
Cumulus Linux
Cisco
cumulus@switch:~$ sudo tzconfg
cumulus@switch:~$ sudo hwclock
NTP
cumulusnetworks.com 27
switch# clock protocol ntp vdc 1
Cumulus Linux
Cisco
Set NTP (e.g. to VDC 1)
cumulus@switch:~$ sudo vi /etc/ntp.conf
cumulus@switch:~$ ntpd –q
Show Management Interface Current Configuration
cumulusnetworks.com 28
switch# show interface mgmt 0
Cumulus Linux
Cisco
cumulus@switch:~$ ifquery eth0
DHCP Relay
cumulusnetworks.com 29
cumulus@switch:~$ sudo vi /etc/default/isc-dhcp-relay
SERVERS="192.168.123.4"
INTERFACES="bridge swp4 swp5"
cumulus@switch:~$ sudo /etc/init.d/isc-dhcp-relay restart
Cumulus Linux
Cisco
switch# configure terminal switch(config)# ip dhcp relay
switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# ip dhcp relay address 192.168.123.4
CLI Basics
cumulusnetworks.com 30
Show command history
cumulus@switch:~$ history switch# show cli history
Cumulus Linux Cisco
Send message to all logged on users
cumulus@switch:~$ echo message | sudo wall switch# send message
Send message to specific user
cumulus@switch:~$ sudo write user-id switch# show users
switch# send session line message
CLI Basics
cumulusnetworks.com 31
Show SPROM information
cumulus@switch:~$ decode-syseeprom switch# show sprom
Cumulus Linux Cisco
Show hardware states (temperature, fan, power)
cumulus@switch:~$ sudo smonctl switch# show environment
Show memory allocation
cumulus@switch:~$ vmstat switch# show processes memory
Show real-time memory usage
cumulus@switch:~$ vmstat 1
Alternative command
cumulus@switch:~$ free
cumulus@switch:~$ sudo sensors
CLI Basics
cumulusnetworks.com 32
Show CPU processes and utilization
cumulus@switch:~$ ps aux switch# show processes
Cumulus Linux Cisco
Show hardware information
cumulus@switch:~$ dmidecode switch# show inventory
Show high level port state
cumulus@switch:~$ netshow interface switch# show ip int br
cumulus@switch:~$ top switch# show processes cpu
cumulus@switch:~$ netshow system
CLI Basics
cumulusnetworks.com 33
Show interface neighbors
cumulus@switch:~$ lldpctl switch# show lldp neigbhors
Cumulus Linux Cisco
Show interface connector information
cumulus@switch:~$ sudo ethtool –m swp1 switch# show interface ethernet 1/1 transceiver
Reboot switch
cumulus@switch:~$ sudo reboot switch# reload
cumulus@switch:~$ netshow lldp
Show ARP Table
cumulusnetworks.com 34
root@leaf01:~# arp –n
Address HWtype HWaddress Flags Mask Iface
10.2.0.254 ether 44:38:39:00:00:29 C eth0
169.254.1.2 ether 44:38:39:00:00:30 C peerlink.4094
169.254.0.1 ether 44:38:39:00:00:08 CM swp49
169.254.0.1 ether 44:38:39:00:00:14 CM swp50
Cumulus Linux
Cisco
switch# show ip arp
IP ARP Table for context default
Total number of entries: 1
Address Age MAC Address Interface
90.10.10.2 00:03:11 000d.ece7.df7c Vlan900
Configure SNMP (Net-SNMP)
cumulusnetworks.com 35
cumulus@switch:~$ sudo vi /etc/snmp/snmpd.conf
cumulus@switch:~$ sudo vi /etc/snmp/snmptrapd.conf
switch# configure terminal
switch(config)# snmp-server host ip-address traps version 2c public
Cumulus Linux
Cisco
https://docs.cumulusnetworks.com/display/DOCS/Monitoring+System+Hardware
Detailed Info
© 2016 Cumulus Networks. CUMULUS, the Cumulus Logo, CUMULUS NETWORKS, and the Rocket Turtle Logo (the “Marks”) are trademarks and service marks of
Cumulus Networks, Inc. in the U.S. and other countries. You are not permitted touse the Marks without theprior written consent of Cumulus Networks. The registered
trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis. All other marks are used
under fair use or license from their respective owners.
§Thank You!
cumulusnetworks.com 36
Bringing the Linux Revolution to Networking

More Related Content

What's hot

Troubleshooting BGP Juniper Examples
Troubleshooting BGP Juniper ExamplesTroubleshooting BGP Juniper Examples
Troubleshooting BGP Juniper Examples
Salachudin Emir
 

What's hot (20)

Deploying IPv6 in OpenStack Environments
Deploying IPv6 in OpenStack EnvironmentsDeploying IPv6 in OpenStack Environments
Deploying IPv6 in OpenStack Environments
 
Deploying Carrier Ethernet features on ASR 9000
Deploying Carrier Ethernet features on ASR 9000Deploying Carrier Ethernet features on ASR 9000
Deploying Carrier Ethernet features on ASR 9000
 
KubernetesとFlannelでWindows上にPod間VXLAN Overlayネットワークを構成
KubernetesとFlannelでWindows上にPod間VXLAN Overlayネットワークを構成KubernetesとFlannelでWindows上にPod間VXLAN Overlayネットワークを構成
KubernetesとFlannelでWindows上にPod間VXLAN Overlayネットワークを構成
 
cilium-public.pdf
cilium-public.pdfcilium-public.pdf
cilium-public.pdf
 
ansible why ?
ansible why ?ansible why ?
ansible why ?
 
Automating OpenSCAP with Foreman
Automating OpenSCAP with ForemanAutomating OpenSCAP with Foreman
Automating OpenSCAP with Foreman
 
Using GTP on Linux with libgtpnl
Using GTP on Linux with libgtpnlUsing GTP on Linux with libgtpnl
Using GTP on Linux with libgtpnl
 
Drive into calico architecture
Drive into calico architectureDrive into calico architecture
Drive into calico architecture
 
TRex Traffic Generator - Hanoch Haim
TRex Traffic Generator - Hanoch HaimTRex Traffic Generator - Hanoch Haim
TRex Traffic Generator - Hanoch Haim
 
Red Hat OpenStack 17 저자직강+스터디그룹_2주차
Red Hat OpenStack 17 저자직강+스터디그룹_2주차Red Hat OpenStack 17 저자직강+스터디그룹_2주차
Red Hat OpenStack 17 저자직강+스터디그룹_2주차
 
Xdp and ebpf_maps
Xdp and ebpf_mapsXdp and ebpf_maps
Xdp and ebpf_maps
 
"SRv6の現状と展望" ENOG53@上越
"SRv6の現状と展望" ENOG53@上越"SRv6の現状と展望" ENOG53@上越
"SRv6の現状と展望" ENOG53@上越
 
Namespaces in Linux
Namespaces in LinuxNamespaces in Linux
Namespaces in Linux
 
Dpdk pmd
Dpdk pmdDpdk pmd
Dpdk pmd
 
DPDK QoS
DPDK QoSDPDK QoS
DPDK QoS
 
Cilium - Fast IPv6 Container Networking with BPF and XDP
Cilium - Fast IPv6 Container Networking with BPF and XDPCilium - Fast IPv6 Container Networking with BPF and XDP
Cilium - Fast IPv6 Container Networking with BPF and XDP
 
Introduction to eBPF and XDP
Introduction to eBPF and XDPIntroduction to eBPF and XDP
Introduction to eBPF and XDP
 
Troubleshooting BGP Juniper Examples
Troubleshooting BGP Juniper ExamplesTroubleshooting BGP Juniper Examples
Troubleshooting BGP Juniper Examples
 
DPDKによる高速コンテナネットワーキング
DPDKによる高速コンテナネットワーキングDPDKによる高速コンテナネットワーキング
DPDKによる高速コンテナネットワーキング
 
Kubernetes networking
Kubernetes networkingKubernetes networking
Kubernetes networking
 

Viewers also liked

20ten final presentation-Cumulus
20ten final presentation-Cumulus20ten final presentation-Cumulus
20ten final presentation-Cumulus
julianasur
 
ONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks WebinarONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks Webinar
Cumulus Networks
 

Viewers also liked (9)

20ten final presentation-Cumulus
20ten final presentation-Cumulus20ten final presentation-Cumulus
20ten final presentation-Cumulus
 
Cumulus Networks Overview
Cumulus Networks OverviewCumulus Networks Overview
Cumulus Networks Overview
 
Cumulus Linux 2.5 Overview
Cumulus Linux 2.5 OverviewCumulus Linux 2.5 Overview
Cumulus Linux 2.5 Overview
 
ONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks WebinarONIE / Cumulus Networks Webinar
ONIE / Cumulus Networks Webinar
 
Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015Open Hardware for All - Webinar March 25, 2015
Open Hardware for All - Webinar March 25, 2015
 
OCP Switch Overview
OCP Switch OverviewOCP Switch Overview
OCP Switch Overview
 
Ansible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network AutomationAnsible & Cumulus Networks - Simplify Network Automation
Ansible & Cumulus Networks - Simplify Network Automation
 
VMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined NetworkingVMware NSX + Cumulus Networks: Software Defined Networking
VMware NSX + Cumulus Networks: Software Defined Networking
 
現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧現代 IT 人一定要知道的 Ansible 自動化組態技巧
現代 IT 人一定要知道的 Ansible 自動化組態技巧
 

Similar to Cumulus networks conversion guide

Cisco data center support
Cisco data center supportCisco data center support
Cisco data center support
Krunal Shah
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
alan moreno
 

Similar to Cumulus networks conversion guide (20)

Day 14.2 configuringvla ns
Day 14.2 configuringvla nsDay 14.2 configuringvla ns
Day 14.2 configuringvla ns
 
Cisco data center support
Cisco data center supportCisco data center support
Cisco data center support
 
Day 13.1..1 catalyst switch
Day 13.1..1 catalyst switchDay 13.1..1 catalyst switch
Day 13.1..1 catalyst switch
 
Icnd210 s02l01
Icnd210 s02l01Icnd210 s02l01
Icnd210 s02l01
 
Configuracion EIGRP
Configuracion EIGRPConfiguracion EIGRP
Configuracion EIGRP
 
CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2CCN3Switching_lab_5_5_2
CCN3Switching_lab_5_5_2
 
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sampleVoiceBootcamp Ccnp collaboration lab guide v1.0 sample
VoiceBootcamp Ccnp collaboration lab guide v1.0 sample
 
Ccnp3 lab 3_3_en
Ccnp3 lab 3_3_enCcnp3 lab 3_3_en
Ccnp3 lab 3_3_en
 
Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014Hardware accelerated switching with Linux @ SWLUG Talks May 2014
Hardware accelerated switching with Linux @ SWLUG Talks May 2014
 
Aruba mobility access switch useful commands v2
Aruba mobility access switch useful commands v2Aruba mobility access switch useful commands v2
Aruba mobility access switch useful commands v2
 
Thebasicintroductionofopenvswitch
ThebasicintroductionofopenvswitchThebasicintroductionofopenvswitch
Thebasicintroductionofopenvswitch
 
Deploying Carrier Ethernet Features on Cisco ASR 9000
Deploying Carrier Ethernet Features on Cisco ASR 9000Deploying Carrier Ethernet Features on Cisco ASR 9000
Deploying Carrier Ethernet Features on Cisco ASR 9000
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
Ccnp3 lab 3_4_en
Ccnp3 lab 3_4_enCcnp3 lab 3_4_en
Ccnp3 lab 3_4_en
 
ACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACITACIT - CCNA Training Course Topic - Switch Stp ACIT
ACIT - CCNA Training Course Topic - Switch Stp ACIT
 
Dc fabric path
Dc fabric pathDc fabric path
Dc fabric path
 
Openstack openswitch basics
Openstack openswitch basicsOpenstack openswitch basics
Openstack openswitch basics
 
PROYECTO VLANS
PROYECTO VLANSPROYECTO VLANS
PROYECTO VLANS
 
Free CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdfFree CCNP switching workbook by networkershome pdf
Free CCNP switching workbook by networkershome pdf
 
Lab6.4.1
Lab6.4.1Lab6.4.1
Lab6.4.1
 

Recently uploaded

CHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICE
CHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICECHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICE
CHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICE
9953056974 Low Rate Call Girls In Saket, Delhi NCR
 
AI Mastery 201: Elevating Your Workflow with Advanced LLM Techniques
AI Mastery 201: Elevating Your Workflow with Advanced LLM TechniquesAI Mastery 201: Elevating Your Workflow with Advanced LLM Techniques
AI Mastery 201: Elevating Your Workflow with Advanced LLM Techniques
VictorSzoltysek
 
+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...
+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...
+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...
Health
 
introduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdf
introduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdfintroduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdf
introduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdf
VishalKumarJha10
 

Recently uploaded (20)

CHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICE
CHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICECHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICE
CHEAP Call Girls in Pushp Vihar (-DELHI )🔝 9953056974🔝(=)/CALL GIRLS SERVICE
 
The Ultimate Test Automation Guide_ Best Practices and Tips.pdf
The Ultimate Test Automation Guide_ Best Practices and Tips.pdfThe Ultimate Test Automation Guide_ Best Practices and Tips.pdf
The Ultimate Test Automation Guide_ Best Practices and Tips.pdf
 
How To Troubleshoot Collaboration Apps for the Modern Connected Worker
How To Troubleshoot Collaboration Apps for the Modern Connected WorkerHow To Troubleshoot Collaboration Apps for the Modern Connected Worker
How To Troubleshoot Collaboration Apps for the Modern Connected Worker
 
A Secure and Reliable Document Management System is Essential.docx
A Secure and Reliable Document Management System is Essential.docxA Secure and Reliable Document Management System is Essential.docx
A Secure and Reliable Document Management System is Essential.docx
 
Payment Gateway Testing Simplified_ A Step-by-Step Guide for Beginners.pdf
Payment Gateway Testing Simplified_ A Step-by-Step Guide for Beginners.pdfPayment Gateway Testing Simplified_ A Step-by-Step Guide for Beginners.pdf
Payment Gateway Testing Simplified_ A Step-by-Step Guide for Beginners.pdf
 
AI Mastery 201: Elevating Your Workflow with Advanced LLM Techniques
AI Mastery 201: Elevating Your Workflow with Advanced LLM TechniquesAI Mastery 201: Elevating Your Workflow with Advanced LLM Techniques
AI Mastery 201: Elevating Your Workflow with Advanced LLM Techniques
 
call girls in Vaishali (Ghaziabad) 🔝 >༒8448380779 🔝 genuine Escort Service 🔝✔️✔️
call girls in Vaishali (Ghaziabad) 🔝 >༒8448380779 🔝 genuine Escort Service 🔝✔️✔️call girls in Vaishali (Ghaziabad) 🔝 >༒8448380779 🔝 genuine Escort Service 🔝✔️✔️
call girls in Vaishali (Ghaziabad) 🔝 >༒8448380779 🔝 genuine Escort Service 🔝✔️✔️
 
BUS PASS MANGEMENT SYSTEM USING PHP.pptx
BUS PASS MANGEMENT SYSTEM USING PHP.pptxBUS PASS MANGEMENT SYSTEM USING PHP.pptx
BUS PASS MANGEMENT SYSTEM USING PHP.pptx
 
%in Stilfontein+277-882-255-28 abortion pills for sale in Stilfontein
%in Stilfontein+277-882-255-28 abortion pills for sale in Stilfontein%in Stilfontein+277-882-255-28 abortion pills for sale in Stilfontein
%in Stilfontein+277-882-255-28 abortion pills for sale in Stilfontein
 
Define the academic and professional writing..pdf
Define the academic and professional writing..pdfDefine the academic and professional writing..pdf
Define the academic and professional writing..pdf
 
Sector 18, Noida Call girls :8448380779 Model Escorts | 100% verified
Sector 18, Noida Call girls :8448380779 Model Escorts | 100% verifiedSector 18, Noida Call girls :8448380779 Model Escorts | 100% verified
Sector 18, Noida Call girls :8448380779 Model Escorts | 100% verified
 
ManageIQ - Sprint 236 Review - Slide Deck
ManageIQ - Sprint 236 Review - Slide DeckManageIQ - Sprint 236 Review - Slide Deck
ManageIQ - Sprint 236 Review - Slide Deck
 
Software Quality Assurance Interview Questions
Software Quality Assurance Interview QuestionsSoftware Quality Assurance Interview Questions
Software Quality Assurance Interview Questions
 
Introducing Microsoft’s new Enterprise Work Management (EWM) Solution
Introducing Microsoft’s new Enterprise Work Management (EWM) SolutionIntroducing Microsoft’s new Enterprise Work Management (EWM) Solution
Introducing Microsoft’s new Enterprise Work Management (EWM) Solution
 
%in Midrand+277-882-255-28 abortion pills for sale in midrand
%in Midrand+277-882-255-28 abortion pills for sale in midrand%in Midrand+277-882-255-28 abortion pills for sale in midrand
%in Midrand+277-882-255-28 abortion pills for sale in midrand
 
8257 interfacing 2 in microprocessor for btech students
8257 interfacing 2 in microprocessor for btech students8257 interfacing 2 in microprocessor for btech students
8257 interfacing 2 in microprocessor for btech students
 
+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...
+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...
+971565801893>>SAFE AND ORIGINAL ABORTION PILLS FOR SALE IN DUBAI AND ABUDHAB...
 
Right Money Management App For Your Financial Goals
Right Money Management App For Your Financial GoalsRight Money Management App For Your Financial Goals
Right Money Management App For Your Financial Goals
 
introduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdf
introduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdfintroduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdf
introduction-to-automotive Andoid os-csimmonds-ndctechtown-2021.pdf
 
Pharm-D Biostatistics and Research methodology
Pharm-D Biostatistics and Research methodologyPharm-D Biostatistics and Research methodology
Pharm-D Biostatistics and Research methodology
 

Cumulus networks conversion guide

  • 1. v Cumulus Linux Conversion Guides Cumulus Networks May 24, 2016
  • 2. Evolution of the CLI §Where did things move? cumulusnetworks.com 2 interfaces { ge-0/1/1 { unit 0 { family bridge { interface-mode access; vlan-id 100; } } } ge-0/1/2 { unit 0 { family bridge { interface-mode access; vlan-id 200; } } } auto bridge iface bridge bridge-vlan-aware yes bridge-ports swp1 swp2 bridge-vids 100 200 auto swp1 iface swp1 bridge-access 100 auto swp2 iface swp2 bridge-access 200 ▪ Cisco ▪ Juniper ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode access switchport access vlan 100 interface ethernet 1/2 switchport mode access switchport access vlan 200
  • 3. Defining a Switch Port cumulusnetworks.com 3 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 auto bridge iface bridge bridge-ports swp1 Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# switchport
  • 4. Adding an IP Address cumulusnetworks.com 4 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 address [ipv4-address/subnet-mask] address [ipv6-address/subnet-mask] Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# no switchport switch(config-if)# ip address [ipv4-address/subnet-mask] switch(config-if)# ipv6 address [ipv6-address/subnet-mask]
  • 5. Setting Speed, Duplex, MTU, and Auto-negotiation for an Interface cumulusnetworks.com 5 cumulus@switch:~$ sudo vi /etc/network/interfaces auto swp1 iface swp1 link-speed [speed] link-duplex [full|half] mtu [1500 - 9216] link-autoneg [on|off] Cumulus Linux Cisco switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# speed [speed] switch(config-if)# duplex [full|half] switch(config-if)# mtu [1500 - 9216] switch(config-if)# [no] negotiate auto
  • 6. Configuring Trunks cumulusnetworks.com 6 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode trunk interface ethernet 1/2 switchport mode trunk Cisco
  • 7. Pruning a Trunk cumulusnetworks.com 7 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 auto swp1 iface swp1 bridge-vids 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode trunk switchport trunk allowed vlan 200 interface ethernet 1/2 switchport mode trunk Cisco
  • 8. Configuring Access Ports cumulusnetworks.com 8 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 100 200 auto swp1 iface swp1 bridge-access 100 auto swp2 iface swp2 bridge-access 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 100,200 interface ethernet 1/1 switchport mode access switchport access vlan 100 interface ethernet 1/2 switchport mode access switchport access vlan 200 Cisco
  • 9. Changing the Native (Untagged) VLAN for a Single Trunk cumulusnetworks.com 9 auto bridge iface bridge bridge-vlan-aware yes bridge-ports glob swp1-2 bridge-vids 1-200 auto swp1 iface swp1 bridge-pvid 100 auto swp2 iface swp2 bridge-pvid 200 ▪ Cumulus Linux /etc/network/interfaces: vlan 1-200 interface ethernet 1/1-2 switchport mode trunk switchport trunk allowed vlan 1-200 interface ethernet 1/1 switchport trunk native vlan 100 interface ethernet 1/2 switchport trunk native vlan 200 Cisco
  • 10. EtherChannels/Bonds cumulusnetworks.com 10 vlan 10 ! interface GigabitEthernet0/19 switchport trunk encapsulation dot1q switchport mode trunk channel-group 1 mode active interface GigabitEthernet0/20 switchport trunk encapsulation dot1q switchport mode trunk channel-group 1 mode active interface Port-channel1 switchport trunk encapsulation dot1q switchport mode trunk interface Vlan10 ip address 10.10.10.10 255.255.255.0 Cisco WS-C3560X-24 12.2(55)SE5 auto bond1 iface bond1 bond-slaves glob swp19-20 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan10 iface vlan10 bridge-ports bond1.10 address 10.10.10.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Cisco
  • 11. EtherChannels/Bonds cumulusnetworks.com 11 interface Ethernet37 switchport mode trunk channel-group 2 mode active interface Ethernet38 switchport mode trunk channel-group 2 mode active interface Port-Channel2 switchport trunk allowed vlan 12 switchport mode trunk interface Vlan12 ip address 12.12.12.12/24 Arista DCS-7148S-R 4.13.5F auto bond2 iface bond2 bond-slaves glob swp37-38 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan12 iface vlan12 bridge-ports bond2.12 address 12.12.12.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Arista
  • 12. EtherChannels/Bonds cumulusnetworks.com 12 feature interface-vlan feature lacp vlan 14 interface Ethernet1/39 switchport mode trunk channel-group 3 mode active interface Ethernet1/40 switchport mode trunk channel-group 3 mode active interface port-channel3 switchport mode trunk interface Vlan14 no shutdown ip address 14.14.14.14/24 Cisco Nexus3064 5.0(3)U2(2c) auto bond3 iface bond3 bond-slaves glob swp39-40 bond-miimon 100 bond-min-links 1 bond-mode 802.3ad bond-xmit-hash-policy layer3+4 bond-lacp-rate 1 auto vlan14 iface vlan14 bridge-ports bond3.14 address 14.14.14.11/24 bridge-stp on ▪ Cumulus Linux /etc/network/interfaces: Cisco
  • 13. Spanning Tree Configuration cumulusnetworks.com 13 auto swp1 iface swp1 mstpctl-portadminedge yes interface Gigabit0/0 spanning-tree portfast Immediately bring an interface configured as an access or trunk port to the forwarding state. ▪ Cumulus Linux Cisco
  • 14. Spanning Tree Configuration cumulusnetworks.com 14 auto swp1 iface swp1 mstpctl-bpduguard yes ! spanning-tree portfast bpduguard default ! interface Gigabit0/0 spanning-tree portfast Enabling/disabling the BPDU guard configuration. ▪ Cumulus Linux Cisco
  • 15. Spanning Tree Configuration cumulusnetworks.com 15 auto swp1 iface swp1 mstpctl-portbpdufilter yes ! spanning-tree portfast bpdufilter default ! interface Gigabit0/0 spanning-tree portfast Enables BPDU filter on a switch port, which filters BPDUs in both directions. ▪ Cumulus Linux Cisco
  • 16. Spanning Tree Configuration cumulusnetworks.com 16 auto swp1 iface swp1 mstpctl-treeportprio 128 interface Gigabit0/0 spanning-tree port-priority 128 Configure the port priority for an interface. The default for both operating systems is 128. ▪ Cumulus Linux Cisco
  • 17. Spanning Tree Configuration cumulusnetworks.com 17 auto vlan1 iface vlan1 mstpctl-treeprio 32768 bridge-ports swp1 spanning-tree vlan 1 priority 32768 Configure the switch's priority for a bridge/VLAN. The default for both operating systems is 32768. ▪ Cumulus Linux Cisco
  • 18. More Spanning Tree Info (Conversion Guide) cumulusnetworks.com 18 https://support.cumulusnetworks.com/hc/en-us/articles/206908397 Spanning Tree Industry-standard Loop Prevention for L2
  • 19. Access Lists cumulusnetworks.com 19 iptables -A {FORWARD | INPUT | OUTPUT} -j {ACCEPT | DROP | POLICE | SPAN | ERSPAN} | -p <protocol> -s <source> --sport [<ports>] -d destination> --dport [<ports>] [<options>] iptables -A FORWARD -j ACCEPT -p tcp -s 10.10.10.0/24 -d 3.3.3.3/24 --dport 80 iptables/netfilter (including Cumulus Linux) access-list <number> {permit | deny} <protocol> <source> [<ports>] <destination> [<ports>] [<options>] IOS Standard Syntax ip access-list extended {<number> | <name>} [<sequence>] {permit | deny} <protocol> <source> [<ports>]<destination> [<ports>] [<options>] IOS Extended Syntax (including NX-OS) ip access-list extended allow_http 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www access-list 10 permit tcp 10.10.10.0/24 3.3.3.3/24 eq www (Example permit http port 80 traffic to 10.10.10.0/24 subnet)
  • 20. Block ICMP Echo Requests on the Specified Switch Port cumulusnetworks.com 20 iptables -A FORWARD -j DROP -i swp1 -p icmp --icmp-type echo-request ip access-list extended block_icmp deny icmp any any echo interface g0/0 ip access-group block_icmp in Cumulus Linux Cisco
  • 21. Block SSH Trafficfrom the Specified Subnet (5.5.5.0/24) cumulusnetworks.com 21 iptables -A INPUT -j DROP -p tcp -s 5.5.5.0/24 --dport 22 ip access-list extended block_ssh deny tcp 5.5.5.0 0.0.0.255 192.50.50.0 0.0.0.255 eq 22 interface g0/0 ip access-group block_ssh in Cumulus Linux Cisco
  • 22. Allow NTP Traffic to Transitthe Switch (UDP Port 123) cumulusnetworks.com 22 iptables -A FORWARD -j ACCEPT -p udp -s 192.168.1.0/24 --dport 123 ip access-list extended allow_ntp permit udp 192.168.1.0 0.0.0.255 any eq ntp interface g0/0 ip access-group allow_ntp in Cumulus Linux Cisco
  • 23. Policing a Physical Interface cumulusnetworks.com 23 -A FORWARD --in-interface swp1 -j POLICE --set-mode KB --set-rate 125000 --set-burst 2000 Cumulus Linux cumulus@leaf1$ sudo cl-acltool -L ip | grep swp1 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp1 any anywhere anywhere POLICE mode:KB rate:125000 burst:2000 Output policy-map sean class class-default police cir 1000000000 interface TenGigabitEthernet1/13 service-policy input sean Cisco
  • 24. Policing DSCP Values cumulusnetworks.com 24 -A FORWARD --in-interface swp2 -m dscp --dscp 10 -j POLICE --set-mode KB --set-rate 31250 --set-burst 2000 cumulus@leaf1$ sudo cl-acltool -L ip | grep swp2 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp2 any anywhere anywhere DSCP match 0x0a POLICE mode:KB rate:31250 burst:2000 Cumulus Linux Output class-map match-all dscp10 match dscp af11 ! policy-map sean2 class dscp10 police cir 250000000 ! interface TenGigabitEthernet1/14 service-policy input sean2 Cisco
  • 25. Policing by Source Traffic cumulusnetworks.com 25 -A FORWARD --in-interface swp3 -j POLICE --set-mode KB --set-rate 12500 --set-burst 2000 -s 3.3.3.0/24 cumulus@leaf1$ sudo cl-acltool -L ip | grep swp3 pkts bytes target prot opt in out source destination 0 0 POLICE all -- swp3 any 3.3.3.0/24 anywhere POLICE mode:KB rate:12500 burst:2000 Cumulus Linux access-list 100 permit ip 3.3.3.0 0.0.0.255 any ! class-map match-all heller match access-group 100 ! policy-map heller class heller police cir 100000000 ! interface TenGigabitEthernet1/15 service-policy input heller Cisco Output
  • 26. Time Zone Configuration cumulusnetworks.com 26 switch# configure terminal switch(config)# clock timezone PST -8 0 switch(config)# exit switch# show clock switch# copy running-config startup-config Cumulus Linux Cisco cumulus@switch:~$ sudo tzconfg cumulus@switch:~$ sudo hwclock
  • 27. NTP cumulusnetworks.com 27 switch# clock protocol ntp vdc 1 Cumulus Linux Cisco Set NTP (e.g. to VDC 1) cumulus@switch:~$ sudo vi /etc/ntp.conf cumulus@switch:~$ ntpd –q
  • 28. Show Management Interface Current Configuration cumulusnetworks.com 28 switch# show interface mgmt 0 Cumulus Linux Cisco cumulus@switch:~$ ifquery eth0
  • 29. DHCP Relay cumulusnetworks.com 29 cumulus@switch:~$ sudo vi /etc/default/isc-dhcp-relay SERVERS="192.168.123.4" INTERFACES="bridge swp4 swp5" cumulus@switch:~$ sudo /etc/init.d/isc-dhcp-relay restart Cumulus Linux Cisco switch# configure terminal switch(config)# ip dhcp relay switch# configure terminal switch(config)# interface ethernet 1/1 switch(config-if)# ip dhcp relay address 192.168.123.4
  • 30. CLI Basics cumulusnetworks.com 30 Show command history cumulus@switch:~$ history switch# show cli history Cumulus Linux Cisco Send message to all logged on users cumulus@switch:~$ echo message | sudo wall switch# send message Send message to specific user cumulus@switch:~$ sudo write user-id switch# show users switch# send session line message
  • 31. CLI Basics cumulusnetworks.com 31 Show SPROM information cumulus@switch:~$ decode-syseeprom switch# show sprom Cumulus Linux Cisco Show hardware states (temperature, fan, power) cumulus@switch:~$ sudo smonctl switch# show environment Show memory allocation cumulus@switch:~$ vmstat switch# show processes memory Show real-time memory usage cumulus@switch:~$ vmstat 1 Alternative command cumulus@switch:~$ free cumulus@switch:~$ sudo sensors
  • 32. CLI Basics cumulusnetworks.com 32 Show CPU processes and utilization cumulus@switch:~$ ps aux switch# show processes Cumulus Linux Cisco Show hardware information cumulus@switch:~$ dmidecode switch# show inventory Show high level port state cumulus@switch:~$ netshow interface switch# show ip int br cumulus@switch:~$ top switch# show processes cpu cumulus@switch:~$ netshow system
  • 33. CLI Basics cumulusnetworks.com 33 Show interface neighbors cumulus@switch:~$ lldpctl switch# show lldp neigbhors Cumulus Linux Cisco Show interface connector information cumulus@switch:~$ sudo ethtool –m swp1 switch# show interface ethernet 1/1 transceiver Reboot switch cumulus@switch:~$ sudo reboot switch# reload cumulus@switch:~$ netshow lldp
  • 34. Show ARP Table cumulusnetworks.com 34 root@leaf01:~# arp –n Address HWtype HWaddress Flags Mask Iface 10.2.0.254 ether 44:38:39:00:00:29 C eth0 169.254.1.2 ether 44:38:39:00:00:30 C peerlink.4094 169.254.0.1 ether 44:38:39:00:00:08 CM swp49 169.254.0.1 ether 44:38:39:00:00:14 CM swp50 Cumulus Linux Cisco switch# show ip arp IP ARP Table for context default Total number of entries: 1 Address Age MAC Address Interface 90.10.10.2 00:03:11 000d.ece7.df7c Vlan900
  • 35. Configure SNMP (Net-SNMP) cumulusnetworks.com 35 cumulus@switch:~$ sudo vi /etc/snmp/snmpd.conf cumulus@switch:~$ sudo vi /etc/snmp/snmptrapd.conf switch# configure terminal switch(config)# snmp-server host ip-address traps version 2c public Cumulus Linux Cisco https://docs.cumulusnetworks.com/display/DOCS/Monitoring+System+Hardware Detailed Info
  • 36. © 2016 Cumulus Networks. CUMULUS, the Cumulus Logo, CUMULUS NETWORKS, and the Rocket Turtle Logo (the “Marks”) are trademarks and service marks of Cumulus Networks, Inc. in the U.S. and other countries. You are not permitted touse the Marks without theprior written consent of Cumulus Networks. The registered trademark Linux® is used pursuant to a sublicense from LMI, the exclusive licensee of Linus Torvalds, owner of the mark on a world-wide basis. All other marks are used under fair use or license from their respective owners. §Thank You! cumulusnetworks.com 36 Bringing the Linux Revolution to Networking